Start Your 3-Day Risk-Free VPN Trial at only $0.99

PureVPN is now Zero-Log Certified by Altius IT, one of the leading independent US-based Auditors. Read More 

How to Setup PureVPN Manually on BlackBerry OS 10 / 10.1?

Admin
Nov 26, 2014
Jun 25, 2019
2 Comments
Download PDF

Follow these steps to setup VPN manually on Blackberry OS 10 / 10.1

Things to Consider:

Before you begin, please make sure that:

  • You have a working internet connection
  • A Blackberry Device.
  • A Premium PureVPN account (if you haven’t bought yet click here to buy)

If you are using BlackBerry 10.1 then you need to import certificate on your Balckberry device. Download the cert from below link and follow below guide to import certificate

Download Cert

How to import Certificate? Please click here.

1 Go to the settings “Tab”

2 On the next screen tap “Network Connections”

3 Now tap “VPN”

4 On the next screen tap “Add new VPN profile”

5 On “Profile Name” write “PureVPN” and on “Server Address” type one of the PureVPN Server Address that can be obtained from here.

6 On “Gateway Type” select “Microsoft IKEv2 VPN server”. Also on “Authentication Type” select “EAP-MSCHAPv2”. Leave “Authentication ID Type” field empty.

7 Scroll down, enter your PureVPN username: purevpn0sxxxxx in “Authentication ID field” and your password in “MSCHAPv2 Password” field.

8 Leave the rest of the settings as it is and tap “Save”

9 Tap on the PureVPN profile to connect to PureVPN server.

10 This screen shows VPN is connecting.

11 You are connected now, Enjoy Pure Freedom!

Please use the comment box for your suggestions & feedback. For additional help, please submit support ticket with errors and screen shots (if possible) or contact our 24/7 live chat.

How helpful did you find this answer?

Comments (2 )

2 Comments

  1. PureVPN Team says:

    Hi James,

    We are sorry for the inconvenience. Can you please tell us what error you are getting so we may assist you in better way.

    Looking forward to hear from you!

  2. james says:

    Mine is not connecting